RPC endpoint for the Polygon network was down

Incident Report for Mysterium Network

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 07:17 UTC

Monitoring

A fix has been implemented and we are monitoring the situation now
Posted Dec 18, 2025 - 10:31 UTC