Blockchain API is not accessible

Incident Report for Mysterium Network

Resolved

This incident has been resolved.
Posted Aug 27, 2021 - 05:50 UTC

Monitoring

A fix was implemented and we're monitoring results.
Posted Aug 27, 2021 - 04:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 27, 2021 - 04:04 UTC

Identified

Polygon Mumbai Network is not available for us at this moment.
Posted Aug 26, 2021 - 22:34 UTC